Okay
  Public Ticket #1386680
Woocommerece
Open

Comments

  • mlp_duhon started the conversation

    Hello!

    I am trying to upload products to my website but I receive this message everytime I complete a listing. I am assuming something is not as updated as It should be?

    Warning: Missing argument 3 for Withemes_WooCommerce::single_product_image_thumbnail_html(), called in /home/memory63/public_html/wp-includes/class-wp-hook.php on line 286 and defined in /home/memory63/public_html/wp-content/themes/simple-elegant/woo/hooks.php on line 178

    Warning: Missing argument 4 for Withemes_WooCommerce::single_product_image_thumbnail_html(), called in /home/memory63/public_html/wp-includes/class-wp-hook.php on line 286 and defined in /home/memory63/public_html/wp-content/themes/simple-elegant/woo/hooks.php on line 
    178

    Also, all of my product photos are blurry. Even the ones that came with the theme import. Please advise on the best photo dimensions or anything to help remedy the issue.

    Thank You!

    Ashleigh

  •  164
    John replied

    Hi mlp_duhon,

    Could you make sure you are using PHP 5.6 or higher on your server and also run it with a PHP memory limit set to 128 MB or higher if possible. You can confirm these bit of information from your hosting provider support.

    Also ensure you are using woocommerce 3.2.5 with the theme.
    Let us know how this goes and we can take it from there.

  • mlp_duhon replied

    Hi John,

    I am using all of the necessary requirements listed above.

    The problem remains the same.

    http://www.memorylanepaperie.com/product/catherine/

    Ashleigh

  •  164
    John replied

    Hi Ashleigh,

    Could we have temporary admin access we see if we can find the cause of this from the backend?

    Thanks.

  • mlp_duhon replied

    Yes! What info do you need from me?

  • mlp_duhon replied

    Not to be pain but are there any updates?

  •  164
    John replied

    Hi mlp_duhon,

    Very sorry about that.

    We need a username password with admin privileges to take a look at this from the backned.
    Should have mentioned that.

    Also note that the cause of the issue might be that the theme has not been update to be compatible with woocommerce 3.2.x

    Thank.

  • mlp_duhon replied

    What email address should I use to send you the info directly?

    Also, if the issue is with the theme, when will it be compatible with woo commerce?

  •   John replied privately
  •   mlp_duhon replied privately
  •  164
    John replied

    Hi mlp_duhon,

    Apologies for the late reply.

    We could not find the exact cause of this. The errors are actually warnings and not actual errors that would cause the site not to function.

    You can disable warnings from showing on the front end from your PHP settings. Have you hosting provider support help with this.

    That should remove them from the front end. There is not exact ETA on when the woocommerce 3.2.x compatibility update will be.

    Cheers.

  • mlp_duhon replied

    Thanks for trying!

    What dimensions do you recommend for the thumbnails to remedy the blurry product photos?

  •  164
    John replied

    Hi there,

    You can upload images around this size:

    Then set the thumbnail size to 180 X 180 or 200 X 200.
    Then the catalog size to 400 X 400 and the single product page image size to 600 X 600.

    Now you can adjust your image sizes up or down if you like but the best would be to set image sizes that preserve the aspect ratio of the original image to avoid any surprises.

    After setting the sizes in woocommerce make sure to regenerate the thumbnails for the sizes to be actually applied to the images.

    Cheers.